Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
Liquid UI Server aka GuiXT Server / Upgrading Liquid UI Server
« Last post by umang@guixt.com on February 02, 2022, 10:46:49 AM »




http://updates.guixt.com/secured/v617_x64.zip
username: guixt.dnld
password: guixt950
 
Below are the steps to update the software
1. Download the new release from the link provided (Version 3.5.617.0), and extract the files (sapproxy.exe and webscript.dll)
2. Make a backup of existing files (sapproxy.exe and webscript.dll) in the current software install location
3. Stop the Liquid UI Service
4. Copy the new extracted files to the software install location  (sapproxy.exe and webscript.dll)
5. Re start the Liquid UI Service

As with any software upgrade, please test your existing scripts before upgrading the production envinronment.

Please check any scripts that has
- Reference to SAP table which is referred by using Non English Language, if so change it to technical name.  You can put the cursor on the table cell and perform F1 to retrieve technical details of the table

22
Issue:
While connecting to S/4 HANA environment using Liquid UI for Windows Mobile/CE, even though a valid license exist, a license error popup shows up on the UI

Reason:
Launching system>status from the menu bar did not launch the usual, expected system status screen.
Instead, it displayed avery restricted subset of the information under the header ?Repository Data? ?

Resolution:
For solution see SAP Note 2658772.

SAP_BASIS version 7.53 has now introduced a new authorization check on system>status.
The contents of this popup is now restricted through the authorization object S_SYS_INFO.
There was no restriction on this in the earlier versions.
In order to get back the unrestricted view, you will need to create a new role containing the above object, or add it to an existing role, with the below field values ?

ACTVT:
03 (Display)

INFO:
USER (to view the ?user data? section)
SYSTEM (to view the ?SAP system data? section)
HOST (to view the ?host data? section)
DB (to view the ?database data? section)
KERNEL (to access the kernel information)
* (to view everything)

23
The purpose of Liquid UI Server is for central software deployment.  No software footprint on user's local machine.

The scripts are developed on developer's desktop using local SAPGUI and local software installation
This way the scripts are accessible to the developer on their own machine, and Liquid UI console window is available for the developer to debug
any issues.  This is the preferred method in a multi developer environment.

The developed scripts are then then deployed centrally using web repository, or network share.

Also when deploying the software centrally using Liquid UI Server, the production and non production environment shoule be executed on different machines
to prevent any disruptions in production environment usage

Liquid UI Server for development can also be executed in console mode as and when need,
which can provide access to the console window for additional debugging at the Server Level



24
There is no impact
We do not use Java or log4j module
25
LiquidUI - SAP NetWeaver AS ABAP SSO
Workflow for iOS and Android Clients

SAP Communication Channels


See Diagram in attached file, which shows the connection from Liquid UI iOS-Android Clients to LUI Server secured using TLS 1.3


From LUI Server to SAP ECC, connection is established as SAP's trusted server SSO, using SAP's digitally signed Logon Ticket.

On both ends of the Server the connections are secured.  One via TLS 1.3 and the other via Trusted Server Logon Ticket


Trusted Server Connection to SAP ECC is compressed, and the SAP ECC Kernel does not support further encryption.  This SAP Native protocol is not https traffic.
Synactive recommends the LUI server be placed close to the SAP ERP Server to the maximize the optimizing feature as well as to ensure security.
Furthermore, the trust relationship established between LUI Server and SAP ECC ensures that no 3rd party can access this Trusted Server Channel.
Trusted Server Connection is needed not only in the Desktop mode, but it is a necessity in the Mobile environment, where there is no Kerberos SSO.  Connection to LUI Server from the Mobile device is protected by TLS 1.3.
26
LiquidUI - SAP NetWeaver AS ABAP SSO


SAP Communication Channels


See Diagram in attached file, which shows the connection from SAP GUI to LUI Server via the standard SAP's SNC interface. There are no changes in SAP GUI other than service principal.  Available only with Cybersafe TrustBroker

From LUI Server to SAP ECC, connection is established as SAP's trusted server SSO, using SAP's digitally signed Logon Ticket.

On both ends of the Server the connections are secured.  LUI Server connects via standard SAP secure channels.  One via Kerberos and the other via Trusted Server Logon Ticket.

27
Use below registry entry to Activate GuiXT in SAPGUI

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\SAP\SAPGUI Front\SAP Frontend Server\Customize]
"GuiXT"=dword:00000001
28
Purpose: To Calculate the sum of two inputfields using Liquid UI WS

Please follow the below steps:

Step-1: Open the Script file "SAPLSTMTR_NAVIGATION.E0100.sjs" or Create it if it is not present in the WS Directory as configured in the "guixt.sjs" file.

Step-2: Add the below Code Snippet and Save it.

//Deleting the Screen Controls
//Liquid UI Code:
del("X[IMAGE_CONTAINER]");
del("P[User menu]");
del("P[SAP menu]");
del("P[SAP Business Workplace]");
del("P[Display role menu]");
del("P[Add to Favorites]");
del("P[Delete Favorites]");
del("P[Change Favorites]");
del("P[Move Favorites down]");
del("P[Move Favorites up]");
del("P[Create role]");
del("P[Assign users]");
del("P[Documentation]");

//Function to Increment the Total Field from the Quantity Field
function Increment(param){
var total1=parseInt(z_quantity);
var total2=parseInt(z_total);
var output=total1+total2;
set("V[z_total]",output);
}

//Design Screen
inputfield( [12,73], "Total", [12,86],{ "name":"z_total", "size":32});
inputfield( [10,73], "Quantity", [10,86],{ "name":"z_quantity", "size":32});
pushbutton([14,93], "@01@",{ "process":increment, "size":[2,12], "using":{ "quantity":"z_quantity", "total":"z_total" }});

Step-3: Enter the Values in the inputfields and Click on the Pushbutton.

Step-4: It will calculate the Sum and display the result in the inputfield.


Refer to the Attachment for clarity....
29
Purpose: Achieving Tab functionality using Arrow Keys for an Editable Input Field.
Pre-requisites:  Liquid UI Android version 4.0.8.0 and above

Steps:
1. Launch Liquid UI Android.
2. Connect to your SAP Server.
3. For Example, navigate to VA01 Transaction and Tap on Right arrow Key on a Qwerty keyboard to navigate to the next Editable input field.
4. Tap on Left Arrow Key on a Qwerty keyboard, it will do a Tab and go to Previous Input Field.


Refer to the Attachment for Clarity....
30

Symptoms
When you use Liquid UI to open a dialog window to select a file, you receive error related to MsComdlg or CommonDialog.
This article provides resolution to the issue.

Resolution:
Download the comdlg32 files(comdlg32.dll and comdlg32.ocx):
Comdlg32 files (click here)
OR
Paste the below link in your browser:
http://updates.guixt.com/downloads/comdlg32.zip

Steps to register the ocx file:
Step 01: After the download of comdlg32.zip
Step 02: Extract comdlg32.zip
Step 03: Place the files in "C:\Windows\SysWOW64" folder
Step 04: Open command prompt as admin and run the below commands:
            cd C:\Windows\SysWOW64
            regsvr32 comdlg32.ocx
Pages: 1 2 [3] 4 5 ... 10